注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天边云E家 shaoruisky

IT博文共享,知识的海洋

 
 
 

日志

 
 

在Linux下安装ies4linux使用网银  

2009-01-10 13:09:49|  分类: linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

国内网银的安全控件基本上是基于MS的Activex技术开发的,由于是MS独有的技术,在Firefox和opera下都无法使用,也就注定了在linux下无法使用网银,但是,现在可以通过模拟的方式来实现在linux下的网银使用。

这里要用到ies4linux这个软件。安装方法如下:

You have to enable universe packages first. It is also recommended that you use the official winehq ubuntu package:

1) Open a terminal

2) Open /etc/apt/sources.list

sudo gedit /etc/apt/sources.list

3) Uncomment (or add) following lines:

deb http://us.archive.ubuntu.com/ubuntu edgy universe

4) Add this line:

deb http://wine.budgetdedicated.com/apt edgy main

5) Close gedit. Update and install wine and cabextract:

wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -

sudo apt-get update

sudo apt-get install wine cabextract

6) Download IEs 4 Linux and install

wget http://www.tatanka.com.br/ies4linux/downloads/ies4linux-latest.tar.gz

tar zxvf ies4linux-latest.tar.gz

cd ies4linux-*

./ies4linux

Note for Dapper users: if you use ubuntu dapper, replace edgy with dapper on lines above.

下载完成后,会有几个提示选项,按照个人喜好选择就行,之后会在桌面上生成一个快捷方式,这样就可以使用IE了。

以工行的网银来说,登录页会提示说当前安全设置禁止执行ActiveX,直接输入卡号,然后点登 录,就会提示下载控件,这个地方直接运行就好了,如果下载下来有可能会安装到wine下去,安装成功后,关闭全部的IE浏览器,重新登录,就能使用了

  评论这张
 
阅读(232)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016