注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天边云E家 shaoruisky

IT博文共享,知识的海洋

 
 
 

日志

 
 

解决ECLIPSE无法打开“FAILED TO LOAD THE JNI SHARED LIBRARY”  

2013-06-29 11:59:57|  分类: 网络技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

这是因为JDK配置错误所导致的现象。

解决ECLIPSE无法打开“FAILED TO LOAD THE JNI SHARED LIBRARY” - MICRO CORE - 天边云E家

一般说来,新购笔记本会预装64位的windows系统,而在网上下载软件时,32位会优先出现在页面中(现在来说是这个情况,但我认为未来64位会越来越普及)。

如果你是64位的系统,却安装了32位的JDK,就会导致上面的情况。

解决办法如下:

  1. 卸载掉原来安装的32位的JDK,然后安装64位的JDK到电脑中。

  2. 重新修改path 和 classpath 两个环境变量。因为在64系统当中,32位软件回安装到program files (*86)文件夹,64位软件会安装到program files 文件夹,当你先前安装32JDK时,你设置的环境变量路径当中当然会包括“program files (*86)”,而这时JDK已经转移到“program files”中了,修改过来即可。

  3. 注意你两次安装的JDK版本号,不一定相同,因为安装时会根据你的版本号建立JDK文件夹,如果两次的版本号不同,在环境变量里也要修改。

现在,Eclipse应该可以正常使用了,快去练习Java程序吧!

扩展阅读:

下载链接:

  评论这张
 
阅读(101)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2016